Pokefreaks

Mods needed:
Forge: get the 1.7.10 Recommended version
Pixelmon: Wait for the countdown and get Pixelmon 3.4.0

An easier step is to just download the server modpack at: http://www.technicpack.net/modpack/details/riks-pixelmon.362440

Welcome to Pokefreaks!